компьютерный форум
Вернуться   Компьютерный форум > Программирование и вебстроительство > 1C (Все версии)

Ответ
 
LinkBack Опции темы Опции просмотра
Старый 06.02.2009, 15:54   #1
Пользователи
 
Регистрация: 06.02.2009
Сообщений: 3
По умолчанию

Как выбрать остатки за определенный период в бухг. конфигурации 1С 7.7
Помогите плиз




mrrose вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
06.02.2009, 15:54
Техник
реклама
По умолчанию

Старый 07.02.2009, 06:29   #2
Пользователи
 
Регистрация: 06.02.2009
Сообщений: 3
По умолчанию

Я так понимаю вопрос сложный для форумчан
mrrose вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 08.02.2009, 14:53   #3
Пользователи
 
Регистрация: 06.02.2009
Сообщений: 3
По умолчанию

Перем МестоХранения;

Так получаются просто остатки, а надо выбрать именно за определенный период и заполнить документ

МестоХранения = глЗначениеПоУмолчанию("ОсновнойСклад");
ТЗ= СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Номенклатура","Справочник.Номенкл атура");
ТЗ.НоваяКолонка("Остаток","Число",14,3);
ТЗ.НоваяКолонка("Сумма","Число",15,2);
ТЗ.НоваяКолонка("Квопродаж","Число",14,3);
ТЗ.НоваяКолонка("СуммаПродаж","Число",15,2);

Сч43 = СчетПоКоду("43");
Сч41_1 = СчетПоКоду("41.1");
Сч41_3 = СчетПоКоду("41.3");
Сч41_4 = СчетПоКоду("41.4");
Сч004 = СчетПоКоду("004");

БухИт=СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.ПериодМ(ТекущаяДата());

спр = СоздатьОбъект("Справочник.Номенклатура");
спр.выборГруппы(1);
спр.Выбрать("Выберите группу товаров", );
Если спр.Выбран() = 0 Тогда
Возврат;
КонецЕсли;
спр.выборГруппы(0);

наценка=10;
Если ВвестиЧисло(наценка,"Ввести наценку %:",10,3)=0 Тогда
Возврат;
КонецЕсли;

УдалитьСтроки();

ВыбРодитель = спр.ТекущийЭлемент();
спр.ИспользоватьРодителя(ВыбРодитель);
спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент() = 1 Цикл
//спТоваров.ДобавитьЗначение(спр.ТекущийЭлемент());
Состояние("Заполняется табл. часть документа");
Стр = "";
Если спр.ТекущийЭлемент().Выбран() = 0 Тогда
ИначеЕсли спр.ТекущийЭлемент().ЭтоГруппа() = 0 Тогда
СчетУчета = "";
Если спр.ТекущийЭлемент().ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
СчетУчета = Сч43;
ИначеЕсли спр.ТекущийЭлемент().ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар Тогда
Если спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.Тара Тогда
СчетУчета = Сч41_3;
ИначеЕсли спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.ПокупныеИзделия Тогда
СчетУчета = Сч41_4;
ИначеЕсли спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.НаКомиссии Тогда
СчетУчета = Сч004;
Иначе //Если ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.Собственный Тогда
СчетУчета = Сч41_1;
КонецЕсли;
КонецЕсли;

Если ПустоеЗначение(СчетУчета) = 1 Тогда
ИначеЕсли КонМесяца(ТекущаяДата()) > КонецРассчитанногоПериодаБИ() Тогда
Стр = "На " + КонМесяца(ТекущаяДата()) + " бухгалтерские итоги не рассчитаны!"+РазделительСтрок+
"Расчет итогов выполняется в режиме"+РазделительСтрок+
"""Операции - Управление бухгалтерскими итогами"".";

Предупреждение(Стр);
Возврат;
Иначе
Остаток = БухИт.СКД(СчетУчета,"К",,спр.ТекущийЭлемент());
Если БухИт.СКД(СчетУчета,"К",,спр.ТекущийЭлемент()) > 0 Тогда
НоваяСтрока();
Товар = спр.ТекущийЭлемент();
Количество = Остаток;
Цена = Окр(БухИт.СКД(СчетУчета,"С",,спр.ТекущийЭлемент())/Остаток, 2)*(1+наценка/100);
Сумма= Окр(Остаток * Цена, 2);
Всего = Сумма;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;




mrrose вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Ответ


Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Вкл.



Текущее время: 00:29. Часовой пояс GMT.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot
Content Relevant URLs by vBSEO 3.5.0 RC2