компьютерный форум
Вернуться   Компьютерный форум > Программирование и вебстроительство > 1C (Все версии)


Закрытая тема
 
LinkBack Опции темы Опции просмотра
Старый 25.05.2010, 14:18   #1
Пользователи
 
Регистрация: 11.01.2010
Сообщений: 22
Thumbs up

1с 7.70.277, Бух учет.

Ток начинаю в программировании, нужно упорядочить справочники.

Хочется так:

Ном = Формат(1,"Ч(0)5.0");
Спр = СоздатьОбъект("Справочник.Контрагенты");
Спр.ВыбратьЭлементы(0);
Пока Спр.ПолучитьЭлемент(0) = 1 Цикл

Если Спр.Код = Ном Тогда
Продолжить;
Иначе
~Н: Если Спр.НайтиПоКоду(Ном,0) = 1 Тогда
Ном = Формат((Ном+1),"Ч(0)5.0");
Перейти ~Н;
Иначе
Спр.Код = Ном;
Спр.Записать();
Сообщить(Спр+" "+Ном);
КонецЕсли;
КонецЕсли;

КонецЦикла;

...Но НайтиПоКоду в цикле использовать нельзя (как оказалось)...
подскажите в каком направлении идти.




kristart вне форума  
Digg this Post!Bookmark Post in Technorati
25.05.2010, 14:18
Техник
реклама
Thumbs up

Старый 26.05.2010, 14:11   #2
Пользователи
 
Регистрация: 11.01.2010
Сообщений: 22
Unhappy

...мож вынести поиск кодов из процедуры в функцию....
....или создать список значений с кодами которые можно использовать...
....
...дайте хоть кой-то совет...., а то топчусь на месте...
kristart вне форума  
Digg this Post!Bookmark Post in Technorati
Старый 26.05.2010, 21:09   #3
Пользователи
 
Регистрация: 11.01.2010
Сообщений: 22
По умолчанию

Цитата:
...мож вынести поиск кодов из процедуры в функцию....
...Всем спасибо, вынес поиск кодов в функцию....помогло, справочник терь в нормальном виде...

Тему можно закрывать.
kristart вне форума  
Digg this Post!Bookmark Post in Technorati
Закрытая тема


Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Вкл.



Текущее время: 11:16. Часовой пояс GMT.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd. Перевод: zCarot
Content Relevant URLs by vBSEO 3.5.0 RC2