компьютерный форум
Вернуться   Компьютерный форум > Программирование и вебстроительство > 1C (Все версии) > WEB расширение 1С 8.0


Ответ
 
LinkBack Опции темы Опции просмотра
Старый 15.06.2006, 08:05   #1
Пользователи
 
Регистрация: 15.06.2006
Сообщений: 4
По умолчанию

Добрый день коллеги, предыдущие посты по поводу ошибки я читал
Вот такую страшную ошибку я получаю при попытке вызова экспортной функции.

System.Runtime.InteropServices.COMException: Unknown name.
at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags invokeAttr, Binder binder, Object target, Object[] args, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParameters)
at _1C.V8.Data.V8.Call(ComObject target, String methodName, Object[] methodParams)
at V8ws.Service1.RublesInWords(String code) in c:inetpubwwwrootv8wsservice1.asmx.cs:line 73



Вот мой код вебсервиса

using (V8DbConnection conn = new V8DbConnection(System.Configuration.ConfigurationS ettings.AppSettings[V8Consts.Database],
System.Configuration.ConfigurationSettings.AppSett ings[V8Consts.UserName],
System.Configuration.ConfigurationSettings.AppSett ings[V8Consts.UserPassword]))
{
conn.Open();

СправочникСсылка_WeB web=new СправочникСсылка_WeB();

ComObject webspr = web.Reference(conn);


byte[] ret = (byte[])V8.Call(webspr,"ВернутьДвоичныеДанныеWeb",new object[] {"2"} );
return ret;


Из общего модуля я вообще не смог функцию вызвать перенес ее в модуль объекта Справочника Web
вот сама функция....
Где ошибка понять не могу уже пол дня.....
Функция ВернутьДвоичныеДанныеWeb(ЭлементХранилища) Экспорт

Если ТипЗнч(ЭлементХранилища)=Тип("СправочникСсылка.Хра нилищеДополнительнойИнформации") Тогда
ТекЭлемент=ЭлементХранилища;
ИначеЕсли ТипЗнч(ЭлементХранилища)=Тип("Число") Тогда
ТекЭлемент=Справочники.ХранилищеДополнительнойИнфо рмации.НайтиПоКоду(ЭлементХранилища);
КонецЕсли;

Хранилище=ТекЭлемент.Хранилище;

Если ТипЗнч(Хранилище) Тип("ДвоичныеДанные") Тогда
ДвоичныеДанные = Хранилище.Получить();
Иначе
ДвоичныеДанные = Хранилище;
КонецЕсли;

Возврат ДвоичныеДанные;

КонецФункции




[Kot] вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
15.06.2006, 08:05
Техник
реклама
По умолчанию

Старый 15.06.2006, 09:03   #2
han
Пользователи
 
Регистрация: 12.05.2006
Сообщений: 79
По умолчанию

функция ВернутьДвоичныеДанныеWeb в общем модуле была объявлена как ЭКСПОРТ?
han вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 15.06.2006, 09:19   #3
Пользователи
 
Регистрация: 15.06.2006
Сообщений: 4
По умолчанию

Цитата:
функция ВернутьДвоичныеДанныеWeb в общем модуле была объявлена как ЭКСПОРТ?
да
[Kot] вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 15.06.2006, 09:19   #4
Пользователи
 
Регистрация: 11.05.2006
Сообщений: 24
По умолчанию

Если я не ошибаюсь у Вас получается следующая ситуация:

[code]с=справочники.Номенклатура;
а=с.ПолучитьСсылку();
stitch вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 15.06.2006, 14:12   #5
Пользователи
 
Регистрация: 15.06.2006
Сообщений: 4
По умолчанию

Всем спаибо разобрался
Надо было галку поставить на общем модуле что запускается на сервере.
[Kot] вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 09.10.2006, 09:52   #6
Пользователи
 
Регистрация: 09.10.2006
Сообщений: 3
По умолчанию

автор темы проблему решил, а я так и не могу.
суть та же - есть WebService,
текст такой:
-------------------------------------------------------------
using System;
using System.Collections;
using System.ComponentModel;
using System.Data;
using System.Diagnostics;
using System.Web;
using System.Web.Services;
using _1C.V8.Data;

namespace V8WebService6
{
public class Service1 : System.Web.Services.WebService
{
public Service1()
{
//CODEGEN: This call is required by the ASP.NET Web Services Designer
InitializeComponent();
}

#region Component Designer generated code

//Required by the Web Services Designer
private IContainer components = null;

private void InitializeComponent()
{
}

protected override void Dispose( bool disposing )
{
if(disposing && components != null)
{
components.Dispose();
}
base.Dispose(disposing);
}

#endregion

[WebMethod]
public string myAuth(string log, string pwd)
{
using (V8DbConnection conn = new V8DbConnection(System.Configuration.ConfigurationS ettings.AppSettings[V8Consts.Database],
System.Configuration.ConfigurationSettings.AppSett ings[V8Consts.UserName],
System.Configuration.ConfigurationSettings.AppSett ings[V8Consts.UserPassword]))
{
conn.Open();
//string ret = (string)V8.Call(conn, conn.Connection, "ЧислоПрописью", new object[] { 100, "L=ru_RU", "рубль, рубля, рублей, м, копейка, копейки, копеек, ж, 2" });
string ret = (string)V8.Call(conn, conn.Connection, "ТЕСТ", new object[] {"", "" });
return ret;
}
}

}
}
----------------------------------------------------------

при вызове функции ваыдается ошибка та же что и у автора
Функция "ТЕСТ" описана в общем модуле myWEB, который помечен и как клиент, и как сервер и как внешнее соединение (в свойствах модуля)
Что я делаю не так?

P.S. вызов встроенной функции "ЧислоПрописью" проходит без проблем



Mopok вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 11.10.2006, 09:30   #7
Пользователи
 
Регистрация: 09.10.2006
Сообщений: 3
По умолчанию

все, извините за беспокойство.
вопрос снят.
все было значительно проще - надо было конфигурацию сохранять по-человечески.
Mopok вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Ответ


Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Вкл.



Текущее время: 19:17. Часовой пояс GMT.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot
Content Relevant URLs by vBSEO 3.5.0 RC2