компьютерный форум
Вернуться   Компьютерный форум > Программирование и вебстроительство > 1C (Все версии) > WEB расширение 1С 8.0

Ответ
 
LinkBack Опции темы Опции просмотра
Старый 25.12.2006, 12:32   #1
Пользователи
 
Регистрация: 25.12.2006
Сообщений: 2
По умолчанию

При переносе проекта с моей машины на сервер возникла такая проблема.
Отказываются работать скрипты веб расширения. В браузере пишет страница выполнена, но с ошибками. В последний раз это была - "Menu - определение отсутствует". Думал, что проблема с правами, дал полные права всем на папку куда установились расширения (1Cv8Web) не помогло. Может кто нибудь сталкивался с этой проблемой.

З.Ы. На форуме предложили переустановить иис, студию и вебрасширение, но в моем случае нет возможности поставить студию на сервер. Может есть менее радикальное решение.

У меня ХП, студия 2003, 1С:Предприятие 8.0 (8.0.17.25) - все работает как надо.
На сервере 2003 виндовз, та же 1С:Предприятие 8.0 (8.0.17.25) те же Web-расширения Версия 8.0.7.9 от 2006_10_10 - не работают скрипты.





sonik вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
25.12.2006, 12:32
Техник
реклама
По умолчанию

Старый 25.12.2006, 15:48   #2
Пользователи
 
Регистрация: 11.09.2006
Сообщений: 67
По умолчанию

З Ы потому я и не юзаю скрипты 1с. Попробуй переустановить веб расширение. вообще то все эти джава скрипты вот тут лежат
C:Program Files1cv8WebScripts (может не тем дал доступ?) а как они попадают в проект я хз.

Но чисто гипотетически вот это

говорит что если ты эти скрипты засуниш принудительно в папку Scripts своего проекта то должно заработать
Львенок вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 25.12.2006, 17:49   #3
Пользователи
 
Регистрация: 07.08.2006
Сообщений: 30
По умолчанию

Цитата:
...
говорит что если ты эти скрипты засуниш принудительно в папку Scripts своего проекта то должно заработать
Ничего никуда сувать не надо. Достаточно на серваке IIS сделать виртуальный каталог 1CV8 c сылкой на папку, где расположены скрипты V8*.js
GRoman вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 26.12.2006, 08:30   #4
Пользователи
 
Регистрация: 25.12.2006
Сообщений: 2
По умолчанию

Попробовал оба предложенных вариант, оба не работают, тут дело несколько в другом... В страничке скрипты ссылаются на "/aspnet_client/1CV8"




нашел у себя на локальной машине(где скрипты работают) эту папку "C:Inetpubwwwrootaspnet_client", но там только папка "system_web" и ни каких следов "1CV8". Что это еще за система с каталогами, иис сам что ли при запуске создает или делает ссылку на папку со скриптами?
sonik вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Старый 27.12.2006, 07:43   #5
Пользователи
 
Регистрация: 11.09.2006
Сообщений: 67
По умолчанию

Млин у меня не получается повторить твою ошибку. Потому ни чем помочь не могу. читай настоящее руководство. Может тебе надо сделать вот что. Удалить net 1.1 удалить веб расширение. поставить за ново. net заново веб расширение. При том именно в этой последовательности. Это должно сработать. Можно конечно там какие то строчки писать...
GRoman: я предположил. Я сразу сказал что не знаю причины этой ошибки.
А почему надо делать так как вы сказали??? у меня виртуальный каталог aspnet_client и скрипты в нем сам 1с прописал.
Львенок вне форума  
Digg this Post!Bookmark Post in Technorati
Ответить с цитированием
Ответ


Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Вкл.



Текущее время: 20:07. Часовой пояс GMT.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot
Content Relevant URLs by vBSEO 3.5.0 RC2